FAQ Componest issues (NOF 9.0)

Discussions and Questions about Fusion 9
elkcamp
Posts: 12
Joined: Tue Apr 15, 2008 2:17 pm

FAQ Componest issues (NOF 9.0)

Postby elkcamp » Wed Jul 01, 2009 11:12 am

Is appears that my website's entire FAQ component database is now missing. All was working fine for months and one day it is gone, ie. the file is empty. Catagories are still there but now reflects zero questions.
It appears that the Q&A data is stored in a .csv file in the /scripts subdirectory. There are actually 3 of these files. T
Anyone have any thoughts on what may be going on?
I can recreate the data (hours and hours), but my real concern is making sure this does not happen again. Has anyone experienced anything like this? Thoughts? :(

User avatar
admin
Site Admin
Posts: 1303
Joined: Mon Oct 24, 2005 2:07 am
Location: Stuart, FL
Contact:

Re: FAQ Componest issues (NOF 9.0)

Postby admin » Wed Jul 01, 2009 6:51 pm

Is appears that my website's entire FAQ component database is now missing. All was working fine for months and one day it is gone, ie. the file is empty. Catagories are still there but now reflects zero questions.
It appears that the Q&A data is stored in a .csv file in the /scripts subdirectory. There are actually 3 of these files. T
Anyone have any thoughts on what may be going on?
I can recreate the data (hours and hours), but my real concern is making sure this does not happen again. Has anyone experienced anything like this? Thoughts? :(
As with any database, you should backup every now and then.

With a flat file database (a csv text file) in particular, you're at the mercy of your Internet connection when publishing.

If the file was open for writing and the connection was lost, the file could be emptied.

It's impossible to say for sure.

You may want to consider a more robust database. Like MySQL.

Chuck


Return to “Fusion 9”

Who is online

Users browsing this forum: No registered users and 2 guests

cron